Hallo,
unter neueren Linux Distributionen funktioniert der alte Kiwix Client nicht mehr.

Das liegt daran, dass die libz.so.1 von xulrunner nicht mehr komatibel ist mit dem restlichem System.
Es erscheint dann fogende Fehlermeldung.

XPCOMGlueLoad error for file /usr/lib/kiwix/xulrunner/libxul.so:

/usr/lib/kiwix/xulrunner/libz.so.1: version `ZLIB_1.2.9' not found (required by /usr/lib/libpng16.so.16)

Couldn't load XPCOM.

Das ganze lässt sich beheben in meinem Falle unter Archlinux mit

sudo ln -sf /usr/lib/libz.so.1 /usr/lib/kiwix/xulrunner/libz.so.1

In andren Distibutionen können die Pfade leicht anders aussehen.

THS